MechMate CNC Router Forum

Go Back   MechMate CNC Router Forum > Computing, Software & Programming > CNC motion control software
Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old Thu 09 July 2009, 10:32
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
Mach3 flaw for slaved gantry motors

Message posted to Mach Yahoo forum:

Hi All

Mach3 running with Smoothstepper. Pair of motors slaved for x-axis under long
gantry. . . .

While using right cursor to jog x-axis, a finger slip over to the Ins(ert)
button moves a single x-motor (skewing gantry). The Del(ete) button runs the
other x-motor.

Anybody seen this before?

The keyboard is slightly unusual (looks more laptop-like, but is packaged for
desktop with PS2 connector)

Our only "cure" for this very dangerous situation is to remove the two offending
buttons. Surely there must be a better solution?

Thanks

Gerald
www.mechmate.com

JB answered there:

Hi gerald,

del and ins are jog keys for A axis

you have to change the keys using config/system hotkeys, or edit xml
file and change the number for this keys to 999 to disable it

for art and brian :

1 -is it a way to disable an hotkey without changing its code to 999 in
xml file ?
in other words, any friendly method to disable a hotkey ?


2 - is it possible to disable the hotkeys for slaved axis automatically
when configuring it ? (in future version of course)

JB DUBOIS

PS for gerald : i will post the same mesage on mechmate forum
Reply With Quote
  #2  
Old Thu 09 July 2009, 11:13
jazial
Just call me: JB
 
Lille
France
Mach3 jogging hotkeys

hi all,

gerald posted a message on mach yahoogroup, saying that del and ins keys on keyboard jogs only one axis motor

in fact those keys are jogging hotkeys for A axis, and in case of slaved axis, this keys still works and jog X axis slaved motor

be very carefull and desactivate this keys if you don't want to twist your gantry

2 ways at this time
- assign hot keys that you can't press easily using config/system hotkeys

- edit the xml file to change the value of those hotkeys to 999
Reply With Quote
  #3  
Old Thu 09 July 2009, 11:56
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
JB

We never had problems with those keys before, but since adding the SmoothStepper, these keys seem to have become alive. (Before the SS, the keyboard was wider, and maybe we did not notice they were live?)

Here is the screen:

Clipboard01.gif

How do I change the 45 & 46 to 999?

The rest of you guys with slaved x motors (J4 on PMDX to X2 motor); what happens if you press the Ins and Del keys while Num Lock is off?
Reply With Quote
  #4  
Old Thu 09 July 2009, 12:11
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
Manually edited the .xml file in Wordpad:

Clipboard01.gif
Reply With Quote
  #5  
Old Thu 09 July 2009, 12:34
jazial
Just call me: JB
 
Lille
France
i guess that smoothstepper xml variables are initialized with A++ and A-- configured as the old default xml file for mach

certainly smooth stepper dev have begun while this values was used in the .xml

feel free to ask evreything about mach3, i'm an expert

and i'm going to be an expert on mechmate too (building has begun, i've just picked up laser cut parts this afternoon)
Reply With Quote
  #6  
Old Thu 09 July 2009, 12:43
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
I checked some old xml files from before our SS installation, and the problem has been there all the time - that is the default of Mach.

But, we never saw it before because the keyboard's NumLock was switched on, which switched off those keys as cursors.

In my opinion it is a bad error from Mach's side.
Reply With Quote
  #7  
Old Thu 09 July 2009, 20:52
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
Oh well, no interest from the Mach guys (or the other MechMaters?) in what seems to be a serious flaw in Mach. I have added some Yahoo correspondence at the top of this thread.
Reply With Quote
  #8  
Old Fri 10 July 2009, 02:20
Greolt
Just call me: Greg
 
Victoria
Australia
The default hotkey settings for both A/U++ and A/U-- are 999 At least on the release candidate which I use.

So maybe that is why you are not getting much reaction from the so called "Mach guys"

Greg
Reply With Quote
  #9  
Old Fri 10 July 2009, 02:50
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
Okay, that explains why nobody is worried about it. Our .xml file was originally from Mach2 days and copied through to later releases.
Reply With Quote
Reply

Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 18:01.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.