MechMate CNC Router Forum

Go Back   MechMate CNC Router Forum > After Building the Beast - Operating , Troubleshooting and Maintenance > Troubleshooting
Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old Wed 09 January 2019, 12:53
Diplocaulus
Just call me: Gary
 
Kearney
United States of America
Machine is down,estop activated won't turn off, config check notes included

Hello, I had my program stop in the middle of cutting and got an emergency stop warning, I can't get it to turn off. I visually checked all the estop buttons and limit switches, nothing seems to be out of place. What should I check next?
I've included the config check notes that show the error. I tried to follow the mitigation directions but the phrase "No LED's on the Diags page under Inputs should be lit up unless a switch is pressed" is confusing. I didn't find a Diags page in the location it provided.

///////////////Configuration Check Facility///////////////////////

Any obvious errors are checked by this facility, passing does not mean
you have no errors, but as more error possibilities are found,
more checks will be added to this facility.
Currently, the most frequenct tech-support errors are checked for.

///////////////LIMIT & HOMING CHECK///////////////////////

Limit Switch found enabled, and activated.
Limit Switch found enabled, and activated.
Home Switch found enabled, and activated.
Home Switch found enabled, and activated.
Home Switch found enabled, and activated.



A switch may be misset in its Active Low setting. No LED's on the
Diags page under Inputs should be lit up unless a switch is pressed
if one IS, then reverse the setting of the LowActive param for that
Switch in the config/ports&Pins/Input Signals tab.
////////////////////// End of Homing and Limits Check ///////////////////////////////////


///////////////OUTPUT Signals Check///////////////////////

No port/pin errors found in output signals.

///////////////End of OUTPUT Signals Check///////////////////////

//////////////// Digitising Probe /////////////////////////
/////////End of Probe Check /////////////////////!.

/////////Motor Settings - Enabled Motors only are Checked/////////////////////!.

A motor Direction pin is set to a port other than 1 or 2, this is probably an error..
/////////Motor Settings - End of Motor Checks/////////////////////!.

Checkup complete , please check any errors listed.

Thank you for checking your Settings.....
Reply With Quote
  #2  
Old Wed 09 January 2019, 13:10
Diplocaulus
Just call me: Gary
 
Kearney
United States of America
I'm wondering if the gecko drive has gone, the power on indicator will turn on for a moment when I reset the machine, but then it goes off and trips the estop. There doesn't seem to be a fuse associated with the gecko drive.
Reply With Quote
  #3  
Old Wed 09 January 2019, 15:37
Diplocaulus
Just call me: Gary
 
Kearney
United States of America
I pulled the gecko drive and checked the onboard fuse, it is showing continuity.
Reply With Quote
  #4  
Old Thu 10 January 2019, 04:38
sphericos
Just call me: David
 
Suffolk
United Kingdom
Can you bypass your estop and limit switch wiring at the BOB just to rule out any issues with cabling?
Reply With Quote
  #5  
Old Thu 10 January 2019, 07:28
Diplocaulus
Just call me: Gary
 
Kearney
United States of America
I figured out the limit switch settings that remove the error, but it seems I'm only getting about 5v from my gecko power supply, so I'm gonna start with replacing that. I visually checked all the cabling and didn't see any signs of wear in the places that would be most expected.
Reply With Quote
Reply

Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
3d printer delta config cnc files, free garymo The Market Place 13 Thu 19 May 2016 18:29
Mach3 Safe_Z config info !? Robert M CNC motion control software 0 Thu 19 September 2013 14:36
Contactor and Mach Estop... salewis 70. Control Systems 4 Wed 16 June 2010 04:33
question on the estop wiring ekdenton 70. Control Systems 4 Tue 18 March 2008 09:07
Jerky movement of the gantries - Limit Overides activated in Mach fabrica Troubleshooting 31 Tue 23 January 2007 09:39


All times are GMT -6. The time now is 03:55.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.