MechMate CNC Router Forum

Go Back   MechMate CNC Router Forum > Electrical & Electronic > 701. Motor Drives
Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old Thu 31 December 2009, 14:06
ikeike
Just call me: isaac
 
bozeman
United States of America
Newbie needs help with figuring out drive configurations (slaved drive for x-axis)

Hi All,
Iím new to the forum and am excited about the prospect of my future MM build. As of now Iím trying to get acquainted with all the cnc terminology and develop a general sense of how this thing will go together and work. The one issue I am having currently is figuring out how the two steppers for the X drive work harmoniously to move the gantry. I understand that each of the two steppers must turn exactly opposite of each other to achieve a synced movement and drive the gantry. I see from pictures on the forum that there are four separate drives, one for each motor. Is the syncing done within the cnc software (Mach3), or is this achieved with some type of wiring configuration within the control box or motors. If you could help describe what is going on here or point me to somewhere within the forum or elsewhere that explains this I would be very grateful. Thanks so much. I look forward to more cnc banter. I canít get enough!
Reply With Quote
  #2  
Old Thu 31 December 2009, 14:39
MetalHead
Just call me: Mike
 
Columbiana AL
United States of America
In the software - Their are settings to slave the drive. Each motor is wired independently.

That is the standard method for the MM. You can share a Gecko on the X drive and not have a slave. Some are using this approach with no issues, but it is not in the plans as a standard config.

Search and reading is your friend on this site. Read a lot
Reply With Quote
  #3  
Old Fri 01 January 2010, 05:16
aniljangra
Just call me: Anil #44
 
Delhi
India
Send a message via Skype™ to aniljangra
Quote:
Originally Posted by MetalHead View Post
You can share a Gecko on the X drive and not have a slave. Some are using this approach with no issues, but it is not in the plans as a standard config.
I guess, that means not sharing one Gecko for both motors but sharing step/dir signals from BoB to two Gecko's driving two X-motors. Sorry if Its me that misinterpreted
Reply With Quote
  #4  
Old Fri 01 January 2010, 05:56
MetalHead
Just call me: Mike
 
Columbiana AL
United States of America
Yes - Thanks for clearing that up.

http://www.mechmate.com/forums/showt...72&postcount=8

Re-read it myself this morning.

and this one also.

http://www.mechmate.com/forums/showt...1&postcount=10
Reply With Quote
  #5  
Old Sat 02 January 2010, 20:58
domino11
Just call me: Heath
 
Cornwall, Ontario
Canada
Also if I can add one more thing, this sharing step and direction signal with two gecko 203Vs. This will not work with the pmdx and the G201 or G202 as I recall. It will work with 2 G203vs. They do not need as much drive current from the pmdx.
Reply With Quote
  #6  
Old Mon 04 January 2010, 21:06
smreish
Just call me: Sean - #5, 28, 58 and others
 
Orlando, Florida
United States of America
Heath.
Correct - you must use the G203 drives if you want to share the step/dir on a "y" cable. The sink/source current is ok for the 203 drives but NOT the others. Mike wrote a VERY lengthy post explaining why......and now I can't find it to refer too....
Reply With Quote
Reply

Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
QJ8060 Drive from CW-Motors Francois 701. Motor Drives 13 Tue 14 September 2010 12:31
Slaving a motor - put its drive in parallel to another drive on the same BOB output J.R. Hatcher 70. Control Systems 34 Mon 16 November 2009 09:13
Off the shelf belt drive? myozman Motors & their mountings 2 Mon 22 June 2009 19:41
How do i wire this which gecko drive to use eloid Archives 1 Mon 05 March 2007 05:07
Anyone has any idea if this drive is something I could use off eBay? Kim Mortensen Archives 1 Thu 08 February 2007 17:40


All times are GMT -6. The time now is 14:47.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.