MechMate CNC Router Forum

Go Back   MechMate CNC Router Forum > Personal Build Histories > MechMates already cutting
Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #361  
Old Thu 21 April 2016, 15:17
Tokamak
Just call me: John #121
 
Monrovia (ca)
United States of America
Robert,
I'll need to re live that g code stuff. The change in the post processor is to remove the Z axis movement commands. Then convert Z down to spindle on and Z up to laser off.
In Mach 3 you connect the spindle port to a pin that turns the laser on/off.

There is a guy on the web called Tweekie on a laser forum. I downloaded his PP file and changed mine to look like his.

I'll look for something more definitive.

Below is a post I made to Tweekie on the Mach3 forum
--------------------
Tokamak:
Tweekie,
Help!!
After reading your build I decided to install an 80W laser on my MechMate. All works fine except turning on the Laser from Mach3.

I cannot get pin 16 to go active. Configured output #1, Port 1, Pin 16

My G code looks like this:

N70G00G20G17G90G40G49G80
N80G70G91.1
N90 (End Mill {0.006 inch}MDF)
N100G94
N110F40.0
N120G00X0.1001Y0.1072M10P1
N130G1M11P1
N140G1Y0.8572M11P1
N150G2X0.1314Y0.8885I0.0313J0.0000
N160G1X0.6314M11P1
N170G2X0.6626Y0.8572I0.0000J-0.0313
N180G1Y0.1072M11P1
N190G2X0.6314Y0.0759I-0.0313J0.0000
N200G1X0.1314M11P1
N210G2X0.1001Y0.1072I0.0000J0.0313
N220G00M10P1
N230G00X0.0000Y0.0000
N240M30
%

Mach3 Ver R3.043.066

I gotta be missing something simple.
-------------------
This is the thread that got me going

http://www.machsupport.com/forum/ind...12444.880;wap2



John
Reply With Quote
  #362  
Old Thu 21 April 2016, 18:16
Tokamak
Just call me: John #121
 
Monrovia (ca)
United States of America
Robert

Good post here on building a post processor for Vetric to laser output.

http://www.buildlog.net/blog/2010/07...ost-processor/

John
Reply With Quote
  #363  
Old Thu 21 April 2016, 19:34
Robert M
Just call me: Robert
 
Lac-Brome, Qc
Canada
Send a message via Yahoo to Robert M Send a message via Skype™ to Robert M
Thks mate.....I'm just about reading ga-zillion info on this at various forums.....trying to gather some....coherent sense for my.....tired & preoccupied overworked mind ...
Thks a lot for this, I'll see to it later and....absorb, synthesise these info...and get back.
Hoo-haa....
Later
PS...edited later....Yay !!..this link is nice info @_# !!

Last edited by Robert M; Thu 21 April 2016 at 19:36..
Reply With Quote
  #364  
Old Thu 21 April 2016, 20:02
Tokamak
Just call me: John #121
 
Monrovia (ca)
United States of America
When I get a chance I'll send the file I use and some pictures of the Mach 3 setup.
Reply With Quote
  #365  
Old Thu 21 April 2016, 20:16
Robert M
Just call me: Robert
 
Lac-Brome, Qc
Canada
Send a message via Yahoo to Robert M Send a message via Skype™ to Robert M
Thks for all this support....but, no rush for this / for me at this point....
Sooo much to read, learn...and set up between work, feeding...a some sleep
Later...
Reply With Quote
  #366  
Old Thu 21 April 2016, 20:48
Robert M
Just call me: Robert
 
Lac-Brome, Qc
Canada
Send a message via Yahoo to Robert M Send a message via Skype™ to Robert M
John...tell me here, about this " Good post here on building a post processor for Vetric to laser output.
http://www.buildlog.net/blog/2010/07...ost-processor/
"
How did you intergate it in your Aspire ??

Copy the "post" from this link ( The complete post is here.) on a notepad or notepad++, then, saved it in the Aspire post file ?
Reply With Quote
  #367  
Old Thu 21 April 2016, 20:59
Tokamak
Just call me: John #121
 
Monrovia (ca)
United States of America
It's been a long time ago. When I finally hit a solution that worked I saved it and moved on. I knew that the laser is just like a mill minus the z axis. I took the mill post processor and converted the z axis up/down and converted it to spindle off/on. Then it's just a matter of routing the spindle signal to a pin that I connect to the laser on off input terminal.

This is all subject to change when I investigate what I really did.
Reply With Quote
  #368  
Old Thu 21 April 2016, 21:16
Robert M
Just call me: Robert
 
Lac-Brome, Qc
Canada
Send a message via Yahoo to Robert M Send a message via Skype™ to Robert M
"This is all subject to change when I investigate what I really did."

I understand all to well, not to worry, I'm not....someone who blames....my acts !!
I've tryed what i suggested, copy then save as in Aspire post file and...not working !!?...
I need to take more time studying all this....
I'll get back at it this WE...
Will post my findings...
Later..& thks for all
Reply With Quote
  #369  
Old Thu 21 April 2016, 21:19
Tokamak
Just call me: John #121
 
Monrovia (ca)
United States of America
Before the weekend I'll send you my PP that works for me.
Reply With Quote
  #370  
Old Thu 21 April 2016, 21:43
Tokamak
Just call me: John #121
 
Monrovia (ca)
United States of America
Attached is my laser post processor. If it doesn't work for you you may need to tweek some of your Mach3 ports and pins.

Get rid of the .doc.txt and rename to .PP
Attached Files
File Type: txt Mach3LASERinch variable Rev1.doc.txt (5.2 KB, 9 views)
Reply With Quote
  #371  
Old Thu 21 April 2016, 21:44
Tokamak
Just call me: John #121
 
Monrovia (ca)
United States of America
It will show up in Aspire Post Processor as

"Mechmate Laser(inch)(*.txt)"
Reply With Quote
  #372  
Old Thu 21 April 2016, 21:49
Robert M
Just call me: Robert
 
Lac-Brome, Qc
Canada
Send a message via Yahoo to Robert M Send a message via Skype™ to Robert M
Thks bud....I'll download it and see this...later, but mostly only tomorrow, enough for to day
Will give news....
Later
Reply With Quote
  #373  
Old Thu 21 April 2016, 22:07
Robert M
Just call me: Robert
 
Lac-Brome, Qc
Canada
Send a message via Yahoo to Robert M Send a message via Skype™ to Robert M
Shame or....just motivated !!?...
I'm "overclocking" my hrs....but couldn't resist trying your post John !!

And....thks to you...all seems, at 1st glance....all very fine...
Proof :

Laser-Mach3-test-run.jpg

moves on Z.... Yey !

Later...
Reply With Quote
  #374  
Old Tue 17 May 2016, 07:31
Tokamak
Just call me: John #121
 
Monrovia (ca)
United States of America
Have not posted in a while. Don't seem to find the time when its not fun. I wasn't happy with my laser post processor or the way the laser was cutting. Had to fight to make anything most of the time. Then Robert M got me into looking at the post processor. Solved most of the file issues. Now I'm having renewed interest in cutting with my MM again! The 80 W laser could not cut through 1/4" birch plywood in one pass. The burnt ash in the top of the cut prevented the laser from penetrating further. Decided it was time to add an air assist to the laser. I added two air nozzles one Y and one X. Now the laser set at 40W cuts completely through 1/4" with no problem. It's fun again! I need to find a way to inject the air along the path of the laser. Like a plasma cutter does it. Now the smoke is a problem. Now my garage smells like burnt wood. Reminds me of camping out.
Found that Instructables.com has a whole area devoted to Laser cutting with many good projects.
'http://www.instructables.com/tag/type-id/category-workshop/channel-laser-cutting/'
Attached Images
File Type: jpg Air Nozzles.jpg (80.3 KB, 224 views)
File Type: jpg Fancy Boxes.jpg (140.6 KB, 223 views)
File Type: jpg clock parts.jpg (111.6 KB, 221 views)
File Type: jpg Alphabet.jpg (122.4 KB, 222 views)
File Type: jpg Box Pieces.jpg (118.9 KB, 222 views)
Reply With Quote
  #375  
Old Tue 17 May 2016, 07:48
Robert M
Just call me: Robert
 
Lac-Brome, Qc
Canada
Send a message via Yahoo to Robert M Send a message via Skype™ to Robert M
Hey John.....glad I came & motivated you to have....fun....while working !
Don’t we all wish that !! @_# !!
Little news of mine, got my laser attachment, now....have to find time to make some kinda of apparatus so an easy swap from router cutting to laser....fun...can be done in a simple jiffy !
Will post some update on my thread soon !!
Keep those projects & pics coming...there fun & inspiring !!
Later bud !

ps....what have you solved in this post ??....what was the issue ?
Reply With Quote
  #376  
Old Wed 18 May 2016, 09:33
Tokamak
Just call me: John #121
 
Monrovia (ca)
United States of America
Robert,
The problem was unusual. If you told mach 3 to 'goto home' when it got there the laser would turn on. Some times it would leave the laser on when it finished and going to Home. I ended up with a burnt line across the part. Very frustrating.

I found that in one of the menus the Charge Pump was checked. Once I un checked that all works good.

There is still one bug but easily avoided through procedure. When loading g code or Regen the code the first time the start button is pushed the laser does not come on. If rewind the code and hit start again it works normally for the rest of the session. If new code is loaded it does it again.

I found that before hitting the start button the first time if I cycle the reset button the laser acts correctly and fires the first time the start button is hit.

There is something being set or cleared on that first cycle but I can at least make it work without standing on one foot and swinging a chicken over my head so I'm happy.

It is probably something simple. But I'm no Mach3 or G-code expert and don't really want to be one. Just want to cut stuff. It works. I need to sit down and get screen shots of the Mach3 setup so I can recover if need be.
Reply With Quote
  #377  
Old Wed 18 May 2016, 09:39
Tokamak
Just call me: John #121
 
Monrovia (ca)
United States of America
BTW I cut this script as a sample for work last night. Of course I misspelled it. It's a miniature sample. The full size will be 3" tall. It is supposed to read

'Communicating with the Universe one bit at a time'
Attached Images
File Type: jpg Communicating.jpg (119.8 KB, 201 views)
Reply With Quote
  #378  
Old Wed 18 May 2016, 19:39
Robert M
Just call me: Robert
 
Lac-Brome, Qc
Canada
Send a message via Yahoo to Robert M Send a message via Skype™ to Robert M
I saw there was a "little" miss spell, but I assumed you intended.....Commuted .....
Reply With Quote
  #379  
Old Wed 18 May 2016, 19:58
Robert M
Just call me: Robert
 
Lac-Brome, Qc
Canada
Send a message via Yahoo to Robert M Send a message via Skype™ to Robert M
John, as for " There is still one bug but easily avoided through procedure. When loading g code or Regen the code the first time the start button is pushed the laser does not come on "....
I tend to understand & see what you mean !!

Not getting into some technical G-code gargon, as you seem not to be to keen getting into this ( and that's very respectable, trust me @_@ )....
I too see this happening, in some odd occasions, to me too !?
It's, for most part ( when that happens to me anyhow ) it's the G-code interface missing the M03 ( a start code in G-code gargon) at the beginning of a G-code task ( see G-code below example.
In my case, for some odd occasion I've yet found why, I get not the M03, but M05 ( which means in G-code language, [router (or power to ?) off] instead of the M03 ?

Check it out if you get either these mistake ( M05 vs M03...or simply, no M03 at all ?)

Code example ( only a few first lines !!) for a routing task....

NWDTOOL N" 3/8 STRAIGHT BIT" T3 D.375 F2. L3. CD2. CL1. SD2. C0)
(NWDSTOCK X21. Y37.125 Z.75 OTC OX0. OY0. OZ0.)
N100 G00 G17 G20 G40 G49 G80 G90
N110 (1st rough pass on X)
N120 ( 3/8 STRAIGHT BIT)
N130 (MAX - Z1.5)
N140 (MIN - Z-.003)
N150 G00 Z1.5
N160 G00 X24.5034 Y.1408 S2000 M03 → this one !! ( make sure it's there and not M05 !!
N170 Z1.05
N180 G01 Z.7735 F100.
N190 X24.1284 Y.1375 Z.3985 F180.

hope this can shed some light on your side....
Later bud !.... ;-)
Reply With Quote
  #380  
Old Wed 18 May 2016, 20:35
Tokamak
Just call me: John #121
 
Monrovia (ca)
United States of America
I didn't notice the misspelling until after cutting. Since it was a sample I didn't bother to recut. The actual will have 3" tall letters.
Reply With Quote
  #381  
Old Mon 13 June 2016, 07:46
Tokamak
Just call me: John #121
 
Monrovia (ca)
United States of America
Cut a sign for work. Cut from 1/2" birch ply.
Attached Images
File Type: jpg Saturn Sign a.jpg (106.2 KB, 114 views)
File Type: jpg Saturn sign b.jpg (108.4 KB, 114 views)
Reply With Quote
  #382  
Old Mon 13 June 2016, 10:55
Fox
Just call me: Fox
 
Amsterdam
Netherlands
Looking very sharp !
If you want to inject air along the path of the laser i think this works:https://youtu.be/ZQkYxfyzk_U
Reply With Quote
  #383  
Old Mon 13 June 2016, 15:14
Robert M
Just call me: Robert
 
Lac-Brome, Qc
Canada
Send a message via Yahoo to Robert M Send a message via Skype™ to Robert M
Very nice !!
Reply With Quote
Reply

Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 23:48.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.