MechMate CNC Router Forum

Go Back   MechMate CNC Router Forum > Computing, Software & Programming > CNC motion control software
Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old Wed 03 February 2010, 08:25
Claudiu
Just call me: Claus #43
 
Arad
Romania
Setting up touch probe

Hello all,

I tried to set up a the Auto Zero sequence in Mach 3.
I followed indications on cockrum.net which I found:

First defined Ports and Pins for the touch Probe. In my case it was necessary to mark active low.
Mach3_ports_pins_probe.jpg

First we need to add a Visual Basic code to the button we want to use. We go to the Operator menu then click on Edit Button Script. The configurable buttons will now be flashing and we click on the Auto Tool Zero button.
This will bring up an editor that may have a Not Implemented message in it. Copy the code into this editor replacing any existing code.
You have to set the .060 value to match the thickness of your touch plate. Save the file (same name) and exit the editor then restart Mach3. You should now be able to press the Auto Tool Zero button and have the Z-axis lower until the touch plate connection is made. I suggest that you try touching the alligator clip and plate together the first few times with the Z-axis nohwere near the table to make sure that this is working.

This is the VB Code written initially by Greg (Greolt) I used for the Setup ( I really cant find the thread where I picked it up from) ZeroProbe.txt

I modified the Code to my demands as follows:
ProbeDist = "-50.0" 'Set the maximum distance to move the Z-axis before probe touches contact plate.
ProbeFeed = "100" 'Set the plunge speed for the probe
DelayTime = "3" 'Set the delay time in seconds from probe verify to start of Z-motion
VerifyTimeout = "10" 'Set timeout to wait for probe verify in seconds
Retract = "10" 'Set distance to retract after probe

The auto Zero routine starts ok with the timeout sequence of 10 sec. waiting for an verification input by touching the probe. Next after 3 more sec. it starts moving down.

All values are respected, only the speed I cannot get to work properly.

The Problem is that it seems to override my stated value of 100 and it moves too slow! My beard is growing meanwhile. It must be mooving with some 5mm/min !!!

Any proposals?
Reply With Quote
  #2  
Old Tue 09 February 2010, 10:36
martin77pl
Just call me: Martin #39
 
Wroclaw
Poland
Hi Claus, I am using Greolt screen as well. Havent tested it yet but probably the script needs to be modified a bit. I combined the screen in such a way to have Tool Zero and Laser Zero in one screen.
Attached Files
File Type: rar mk3.rar (15.5 KB, 99 views)
Reply With Quote
  #3  
Old Mon 15 February 2010, 10:04
dragonfinder1
Just call me: Dave #49
 
Astoria, Oregon
United States of America
Here are the threads I used to get the xyz probe. lots of good info here.

http://www.cnczone.com/forums/showthread.php?t=56079

http://www.cnczone.com/forums/showth...be+code&page=3
Reply With Quote
Reply

Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Touch Screen Panel Size KenC 80. Computer Hardware & Software 6 Sat 01 August 2009 19:42
Digitizing Probe domino11 50. Toolheads 11 Thu 26 March 2009 18:19
Touch probe - $99 aminear The Market Place 3 Wed 25 March 2009 10:05
Touch Panels & Interface Design ozanblotter The Market Place 3 Fri 23 May 2008 00:23


All times are GMT -6. The time now is 04:16.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.