MechMate CNC Router Forum

MechMate CNC Router Forum (
-   Construction started, but not cutting yet (
-   -   Welding up the Table - Pretoria S. Africa (

CoRn3 Wed 13 July 2011 04:04

Some new pics:

Still have loads to do (2nd spindle, cable chains, dust extraction). Y-car motors are on temporary mounts, will be turned horizontally soon....

On the subject of cable chains: the original plan was to make my own once the machine is running. The spindle's cooling pipes are a nightmare to control without cable chains though - I am seriously considering buying some for the gantry at least, and then machining some for the X-axis.

Dust extraction will be rather interesting as well; we have a gantry in the factory that runs over the machine, which severely limits how high I can go above the machine with the dusthose. The length of the machine also makes for some issues with swing arms.

Curious thing though: we are running two BOBs with 8 geckos, and mach3 will not pick up the second BOB. If I enter the second BOB's address in mach's "port 1" slot, I can control it - but not in the other slot! I am still running the demo version of mach, maybe it's limited to one port? No one seems to know, will see soon when I upgrade the license.

I will load some better pictures when I have my camera with me.

KenC Wed 13 July 2011 05:25

Did you daisy wheel your BOBs?

CoRn3 Wed 13 July 2011 05:45

Originally Posted by KenC View Post
Did you daisy wheel your BOBs?
Ken, I'm not quite sure what you mean?

I have a PCI card with two parallel ports, and have one parallel port on the motherboard. Each BOB is connected to a parallel port. I got the addresses for each port from device manager, and entered it in the ports and pins box.

Both work when I enter their addresses here:

Neither work when I enter their addresses here:

Obviously I use the correct addresses, have the "port enabled" check box ticked.

Therefore I think everything is fine and working, but that the issue lies with mach? Hopefully the "full" version won't have the issue? Or maybe I'm just missing something obvious....

KenC Wed 13 July 2011 06:12

page 61 Mach3 Manual

CoRn3 Wed 13 July 2011 07:36

Yip, that's what I did, with above mentioned results.

MetalHead Wed 13 July 2011 07:42

Check the box to enable the port.

danilom Wed 13 July 2011 07:55

Mike he said it was checked.
I read one on the zone that even if the port was external pci card, one guy had to use the option in BIOS for LPT status ENABLE. Its worth to look if you have something like that in bios (advanced options or integrated peripherals).
But as they both work when used as port#1 it sure looks like something with mach. Try newest stable version from their site.

MariusL Sat 16 July 2011 02:14

Both ports must be set as EPP (Enhanced Parallel Port) in the BIOS or window Control Panel. The device drivers will not read any port pins if the port is not set to bi-direction (EPP).
Secondly, the parallel port card must be EPP or better, but you have established that already as it works as port one.

MariusL Sat 16 July 2011 02:19

Originally Posted by CoRn3 View Post
Therefore I think everything is fine and working, but that the issue lies with mach? Hopefully the "full" version won't have the issue? Or maybe I'm just missing something obvious....
Sorry, I just noticed this remark. Yes the unlicensed version does not enable the second port. You can set it up but it will not work. Once you install the licensed Mach, it will all come together.

CoRn3 Wed 10 September 2014 09:02

Some feedback after 3 years...

This machine worked very hard, often around the clock. It was an absolute pleasure for just over a year. The business unfortunately didn't make it, and the machine ended being sold off.

Apparently it got sold to someone else again, who contacted me today to try to source some missing parts - hence my trip down memory lane

I've worked on a couple of other machines since the mechmate, and had loads of problems with things that break or just stop working. On an older Morbidelli, it actually once meant paying someone R3000 to come and install the contents of a "stiffy drive" to solve the software problem - obviously I had to wait a couple of days, and obviously the tiny bit of information couldn't be emailed.... Don't even get me started on the servo drive that had to be replaced.

On the mechmate, nothing ever broke that I couldn't fix. I was never out of production for more than a day. I miss those days - the mechmate truly is a design classic.

isladelobos Tue 16 September 2014 03:07

Thanks for the feedback.

I think, was a very impressive machine.
You always can make another :)

Fox Tue 16 September 2014 11:05

massive, is that a granite bed your are using ?

MariusL Tue 16 September 2014 11:11

I was wondering when that machine was going to live again. I saw it some time ago just lying in pieces under some scrap stuff. It was not a pretty sight to see such a machine being wasted.

laketec Sun 13 March 2016 05:39

Hello everyone, you can call me Sam.

All times are GMT -6. The time now is 01:29.

Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.