MechMate CNC Router Forum

MechMate CNC Router Forum (
-   Troubleshooting (
-   -   Strange cut path glitch - loose pinion on shaft (

Darin Fri 06 April 2012 23:31

Strange cut path glitch - loose pinion on shaft
I've cut this file 100's of times on my previous little hobby machine and never had this problem. I have noticed some occasional irregularities in other things i've been cutting but this is the first time iv'e really come up against completely unacceptable results.Today was my first time to cut this on the Mechmate. In the photo you can see where the cut comes back almost to itself it doesn't line up. It's nearly a 1/4" out of alignment. I don't believe this is mechanical such as loose pinions the router is rock solid when the machine is holding position and this error repeats absolutely identical every time it cuts.


Anyone seen this kind of thing before?

I have been searching and reading and was sure it was related to the "constant velocity" settings in mach but switching to "'exact stop" produced the identical error. I re-made the cut paths in Vcarve pro. just to make sure the file wasn't somehow corrupt.

I'm really not sure what direction to go next. I didn't ever feel like my gecko/motor tuning via the tuning pot screws on the gecko's made much difference. Could that be the root of this problem?

Thank for any sugestions

Gerald D Sat 07 April 2012 00:28

Darin, in the right hand picture there appear to be square shapes . . . . are these shapes measuring out correctly?

Also from the right hand picture, all the curved outlines seem out of place. Those to the right are higher than those on the left?

My first guess, if your X is top to bottom and Y left to tight, is that one of your X motors on the gantry is just idling along and not pulling its weight.

Darin Sat 07 April 2012 02:27

Yes the squares shapes measure out correct. And yes the x axis is top to bottom. I hadn't considered the gantry was getting out of square from a dragging motor but you can be sure I will check that out first thing in the morning.

Thanks so much!

Gerald D Sat 07 April 2012 02:42

Are those squares actually square? (are the diagonal measurements the same?)

Gerald D Sat 07 April 2012 02:44

1 Attachment(s)
Are all of these supposed to be the same thickness?

IN-WondeR Sat 07 April 2012 03:38

It does look like the same problem I had when a motor was disconnected and it only pulled on one motor on the x axis..

Check your connections to your motors...

alan254 Sat 07 April 2012 05:35

Had problem like that. Check X drive spring tension, and lubricate Your nylon washers. Mack sure your motors are not over tight.


Darin Sat 07 April 2012 12:45

Thanks for the replies everyone.
The square parts in the middle seem right. Maybe theres just not enough area involved to see the error but the hole measures perfectly squarie measured with calipers cross corners and with ayou square. I also tried taking the scrap from the middle stacked together turned any way they match up. Yes this object is drawn concentric and should cut uniform in all the areas your pointing out.

As suggested im checking for bind at the motor pivots and cleaning oiling. My gut is telling me its a computer /software issue because the error is perfectly uniform everytime im not loosing steps either. I cut the path and zero is still dead on. I cut it again without removing the part and it followed the same exact previous path.

JamesJ Sat 07 April 2012 13:31

I'm very new to this so take this with a grain of salt.
Looking just above the top of keyhole in Geralds pic, post #5, there appears to be a displacement in the Y axis. With the square being cut correctly and displacements in x and Y I would look at the tool path generation. Possibly one of the profile paths has the wrong inside vs outside setting?

Darin Sat 07 April 2012 13:44

That's exactly what I thought and went to first. Its cutting exactly the same error so it would seem the gcode has to be wrong. The cutpath looks right in the preview screen in both Mach and vertical though.

I tuned the Gecko's this morning, verified the x axis motors were working cleaned up and lubed thesunlight motor pivot points and tried the cut again. Absolute identicle error.

Im going to regenerate the gcode again and write a quick similar cutoff
path try to see if the problem is just this gcode.

Gerald D Sat 07 April 2012 14:10

Darin, cutting the square holes may be lighter cuts than cutting the outline, and the mechanical problems show up with the heavy cuts.

A loose grubscrew on a pinion will also cause something like this

Try cutting this file the other way around (reverse the direction). If the problem flips over then you have mechanical slop/slack somewhaere.

Darin Sat 07 April 2012 14:50

Its not the cutpath. I made a quick path of 3 8" circles nested close together so an outside cut has to reverse where the circles converge similar to the original file. It cuts with similar error.

On your guidance Gerald I then changed the circles to cut along the short axis. The error is gone along the short direction. It must be mechanical. I've had the grubscrew problem before and i've checked repeatedly today by gently bringing the machine to the stops then applying full power against the stops. In this test the motors are absolutely locked. So I don't think its slipping pinions. Its an exactly repeating and not at all random error is there a clue in that?

My next idea is to cut some circles mark their axis direction and stack them to see if their slightly oval.
Thanks for all your help so far

Darin Sat 07 April 2012 14:54

It just occurred to me if a pining slipped or similar then the 0,0 point would change. Thats mot the case I can cut these files repeatably without reseting the origin and the machine follows the exact same errored path

Darin Sat 07 April 2012 15:37

Well the 8" circles tell the tale. If stacked with the axis direction as cut or one turned 180any degrees they match perfectly. But with one turned 90 degrees there's obvious overlap showing im not cutting round at all its about 3/16 error. With a consistent bump in the same spot everytime. I cut them with tabs and repeated the cuts 3 times without re-setting the origin. It followed the same path all three times exactly. I cut them putting as little stain on the machine as possible at 75 ipm three depth pases in 1/2" osb.

I have no idea what to check next!

KenC Sat 07 April 2012 23:06

Tune your motor acceleration & your max speed lower. May help.

Darin Sat 07 April 2012 23:40

cutting speed doesn't seem to matter i've tried various settings from 75ipm up to 300 ipm above 300 everything degrades significantly. But it still cuts like there's really no strain at 500 ipm, but not very accurate at all.

Tonight i re-installed windows and Mach. I didn't fix anything and caused a new problem. Now if the cutter is down table significantly and i hit "go to zero" in Mach. The x axis completely quits responding and stalls. Seems like its tripping the gecko circuit breaker. It happend twice before I figured out what was causing it. Once it happens the x axis is completely dead but will reset if I power the control box off and back on. I'm not sure how re-installing the software caused this new problem but its never done that before. If it's tripping gecko it's tripping the x and slave axis simultaneously.

Work is backing up I'm under alot of pressure to find a solution and quick :(

Gerald D Sun 08 April 2012 00:27

Switch on the steppers, switch off the router/spindle, grab hold of your collet and really yank the machine around HARD. Something is loose. After grubscrews, the next suspect is a loose V-slide (tighten the eccentrics).

Darin Sun 08 April 2012 10:59

That's just not the case. I've thoroughly checked. Nothing flexes wobbles bends or moves until I push hard enough to derail the car. As further verification when I air cut (no strain on the mechanical parts) the cutter follows the exact same path. Im leaving the parts previously cut on the machine the cutter follows the previous cutpath perfectly while touching nothing.

danilom Sun 08 April 2012 11:28

try to change axis step/dir to other output from BoB. swap axis outputs etc...

also... try other LPT cable

Darin Sun 08 April 2012 12:53

Thanks Danilo,
I'll make the switch at the pmdx as soon as I can het back in the shop. I bought the cord through Metalhead mike. I assume he has sold lots for this purpose I doubt its the culprit but i'll look into anything at this point.

I've been thinking about what I've cut and it's probable that this problem has been present back to when I first got the machine working. I just hadn't realized it till now when I cut somthing where its shows.

Darin Sun 08 April 2012 13:41

I just had a thought! During my build I bought a power supply that was to small and rather than send it back I bought another one and used two. Instead of hooking them togeather I used one supplyI for two gecko's and the other for two gecko's. Im wondering if a variance in the power outputs between the two supplies might be causing the whole problem.

Richards Sun 08 April 2012 17:39

Without an oscilloscope, it's hard to see if both power supplies are putting out equal voltages. Some multimeters have a fast enough sampling time to show the AC component of a DC voltage. You can try checking things by reading the DC output with your meter on the AC setting. The voltage shown will be the "ripple". It should be less than 5% of the DC voltage. Be sure that you're measuring the ripple when the motors are running under load.

If the power supplies were causing the problem, I don't think that the cut would be repeatable.

Stepper motors "step" once per pulse. If they miss a step because they're overloaded, they will sound terrible. I don't remember ever having a stepper motor miss steps when I couldn't clearly hear the motors "complaining".

Cutting circles uses both the X-axis and the Y-axis motors at the same time. Why not cut a square and inside the square, cut diagonal lines between the corners. The square uses only the X-axis or the Y-axis as it cuts each side. The diagonal lines would use the X-axis and the Y-axis together with equal steps going to each axis. Check that the start points and the end points are at the corners of the square. Also, be sure that the cuts are deep enough to load the motors. If the square is square but the diagonal cuts wander, then you know that mechanically each axis is working properly when it runs independent of the other axis, but that electrically something is happening when the X-axis and the Y-axis run at the same time.

Darin Sun 08 April 2012 18:00

Thank you very much for the input. I have to admit testing for a ripple pattern with my multimeter is way over my head. I might ask for some more intense help with that if its determined to be required. I simply tied the two supplys together thinking that would have to equal things out. It made no difference.

I know with complete confidence im not loosing any steps. I've been running the same cut path over and over it always follows the same curf and returns to the same home position.

A square test cut with diagonals sounds like a good idea. This afternoon i've switched the x and y axis at the pmdx and nothing changed. I've also tried several changes in mach. Nothing seems to make any difference.

Watching the same cut over and over and examining the cut pieces has made somthing else apearant to me. As the machine travels around the circle there are two spots each time where it seems to jump slightly off course. Its always in the exact same spots. Its not mechanical error its definately movement generated by the steppers. It shows in the cut pieces as about a 1/16" jut that smooths back into the shape. I have a feeling if I could solve that it might fix it all. Its seems like the computer is sending steps that arnt correct.

Gerald D Mon 09 April 2012 00:17

You still need to do this:

Originally Posted by Gerald D View Post
Try cutting this file the other way around (reverse the direction). If the problem flips over then you have mechanical slop/slack somewhaere.

Gerald D Mon 09 April 2012 00:28

Suggest you stick to using the cutting pattern from the photos.....changing the test cut just causes confusion.

You are not loosing steps....thus your power supplies/drives are okay.

You see the problem in one axis direction only....thus the software is okay.

Look very hard for that loose grub-screw that is riding loose on the flat spot of the motor shaft. Lower the motors from the racks, switch them on, use a pliers to turn the pinions back and forwards until the motors jump a step.

IN-WondeR Mon 09 April 2012 03:39

Could it perhaps be a missmatch of the steps pr unit that is setup wrong in the config?

Darin Mon 09 April 2012 12:55

Well im happy to be sailing along with everything working and making up for lost time. Although a little embarrassed to have spent so much time barking up the wrong trees.

Gerald nailed it with his last post and his suspicions all along. I draped the motors again and turned the pinions with pliers and both x axis pinions would move slightly and re-tighten.

What I learned that might help someone in the future:

1. Always hang on every word Gerald writes! (I knew this but wondered down several time wasting paths anyway in my haste to get back up and running)

2. At the first sign of any errant cuts. Drop the motors and turn on holding power to them and grab the pinions with pliers and twist. No other method of checking them for slipping will do! My idea of powering against the stops was flawed because the pinions were catching and not slipping till the direction was reversed. And o had on several occasions put an allen wrench in the grub screws and determined they were tight. (Because of the previous locktight and tight without pliers on the allen wrench wont do.

Thanks again for everyone's help especially Gerald

Gerald D Mon 09 April 2012 14:10

Everyone has heard of the loose grub (set) screw problem, but many don't seem to realise that this results in only a slight wobble of the pinion gear . . . . the gear does not rotate continuously around the motor shaft. So the machine still returns to 0,0 but it goes off the intended path and returns to it again.

IN-WondeR Mon 09 April 2012 15:00

I'm using grub screws with an pin end, which is bored into the shafts. Then munted with loctite screw fix. They will not move what so ever.

KenC Tue 10 April 2012 00:02

I find the above set screw tightening sequence very reliable. The set screw will bite into the shaft solid & jam the set screw from loosening.

You can add a dap of locktite if you wish.

All times are GMT -6. The time now is 10:25.

Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.