MechMate CNC Router Forum

MechMate CNC Router Forum (
-   About this Forum (
-   -   Quick Question, if I am replacing a faulty stepper... (

Diplocaulus Mon 22 October 2018 16:58

Quick Question, if I am replacing a faulty stepper...
Do I just rewire and bolt on the new one and move on, or is there another step regarding software I need to consider? I am new to my job, and have picked up a lot fast, but I think before I got here the z axis was sent into the spoilboard a few times, so when I zero the z axis, it all appears alright but when I tell it "goto zero" it sends the bit into the material. Long story short I think it's skipping gears, and think I should replace the z axis stepper. Will the new motor (same make and model as previous) need any sort of registration to the mach3 software, or will it just run?

MetalHead Tue 23 October 2018 07:39

It should just run.

What motor is it? You may also have an issue with your lift cylinder. The piston arm that supports the weight. Where is this MechMate working in an company environment?

bradm Tue 23 October 2018 11:38

As Mike said, stepper failure is really, really rare.

In theory, the lift cylinder balances your Z-axis, so that if the motor is completely removed the Z axis still stays in the same position. If the lift cylinder is too powerful, the axis goes up, if not powerful enough, it goes down.

In practice, the lift cylinder is often off by a pound or two, but the motor can overcome it. While I'm at it, the lift cylinder should be installed "upside down", so that the lubrication inside the cylinder runs down to the piston seal at the bottom, and not vice-versa.

You appear to describe a symptom where the axis holds steady until you attempt to move it, and then bit moves downward. I can think of a number of ways this can happen:

- The Z axis is set up backwards.
- The Zero point of the axis in the software is actually below the spoilboard
- The pinion gear is loose
- The wiring to the motor has a break
- The driver for the motor has gone bad
- The control signals for the driver are bad.

If you pull the motor out of the rack does the gantry go up or down? With a lot of force or a little?
If you jog the axis upwards after you zero it, does it move? Upwards? Does jogging the other way go in the other direction?

Everything you've described sounds more like a software issue, because the axis does not move until you tell it to. If it's actually disconnected due to a bad motor or wire, I would expect the imbalance to send the axis all the way up or all the way down whenever the power is off. The fact that the spoilboard has been hit a few times tends to confirm that the software setup isn't quite right - something about the zero-ing procedure isn't well understood.

Diplocaulus Wed 24 October 2018 08:08

We've only had the machine a couple months, in a moderate use industrial environment.
We cut eps foam and PU foam, so there isn't a ton of resistance from the material. We can run PU foam too fast but can run EPS as fast as the machine will go, most of the time. I can zero the motor using a tool setter, at which point it lowers slowly, makes the touch, then retracts slightly. If I hit goto zero, the motor then retracts slightly more and drops to the z zero. Most of the time it will make a "chonk" sound in the moment it changes direction from up to down in the "goto" function, then plunges the bit into the material. It is eps foam in this case so no worries, but from that point on the zero is miscalculated and will no refer to the job zero in relation to the machine zero, so it will make it's final pass (fairly consistently) about 1/4" into the spoilboard. Before I worked here the bit had been driven into the table a few times, during setup or bad files, etc. I was thinking the z stepper had maybe been damaged during this time. When I watch the "auto tool zero" and "goto zero" functions very closely at the pinion, the motor seems to be acting up, but it could be a loose gear. I will check that.

bradm Wed 24 October 2018 08:21

Okay, you've clearly got a handle on the software side, so I will flip to:

- Pinion gear grub screws on rack
- Pinon and rack not meshing cleanly - the Chonk
- - wear on the rack or pinion.
- - spring not strong enough to hold pinion engaged, especially when:
- - Speed of movement to zero is faster than all other moves, and outruns the system.
- Motor not powerful enough / axis unbalanced
- Motor dead

Fingers crossed it's your pinion gear grub screws.

Diplocaulus Wed 24 October 2018 08:52

I did find the gear was loose, it didn't appear to be moving independent of the shaft but after marking it have seen otherwise. Thanks, I'll see if tightening it fixes the problem.

Diplocaulus Wed 24 October 2018 16:40

So, the gear was loose but I have have tightened it and have still gotten the z to dive into the material by hitting "goto zero." The z is highlighted red on mach3, which I haven't figured out yet. We have some limit switches but I am not sure if they work yet, I am wondering if setting soft limits would help the z axis issues.

bradm Thu 25 October 2018 20:21

Man, I liked it better when we had a single symptom and naive writers <grin>

I'm not a mach3 guy, so maybe someone else can help with that. That red seems likely to indicate we don't have the zero we expect. From what I see of internet searches, it means that the Z axis is not homed. Do you actually have limit switches for the Z? That seems weird. Is there a Z touch-off plate that isn't in use? That would be consistent with diving as low as you can, trying to find the touch-off.

I think you need to figure out what the correct Z zeroing procedure is for this machine.

And I suspect all the crashes are what loosened the grub screws.

Richards Mon 29 October 2018 07:14

What I noticed is that you've written about a "machine zero" and a "job zero". To me, that means that the "machine zero" is found by using a touch plate laid on the spoil board and the "job zero" is found by placing the touch plate on top of the material that you are cutting.

For finding the "machine zero, the procedure to use is to put the z-zero metal plate on spoil board, and then use the Mach3/4 canned cycle to set the real zero (zero = sensed contact point - thickness of contact plate). Doing that will accurately set the zero point to be the surface of your spoil board. If your CAM software program uses the spoil board as "zero", then you are ready to run.

If "job zero" is referenced to the top of the material, then your "job zero" is off by the thickness of the material if you use the "machine zero" procedure. So, if "job zero" is referenced to the top of the material that you are cutting, then place the z-zero metal plate on the top of the material (instead of on top of the spoil board) when you zero the z-axis. By doing that, the top of the material becomes the z-zero "zero" point and all z-axis cuts would require a negative distance in the g-code file.

Diplocaulus Tue 30 October 2018 13:05

Thanks guys, it's not solved yet but we are replacing the spindle so I can't play with it at the moment. I have a feeling the gas spring may have been the culprit, it was mounted correctly and is still lifting but seems really jerky after I have gotten it out of the machine. We will take a closer look at the software when we install the new spindle and I'm sure something will stick out. I'll keep you updated.

Diplocaulus Tue 13 November 2018 08:43

Hello, I'm back to ruin some days. Thanks again for all the replies, I'm trying to isolate the problem. We replaced the spindle with the water cooled Huangyang setup, and while we are having a couple issues there, unfortunately the z axis issue is back. Lemme tell you what I know/don't know.

1. The gas spring was misaligned slightly to the z axis movement. It was pushing against it's part of the gantry and making the "chonk." I saw this while the spider was off the machine and fixed it. It no longer makes the "chonk" but still dove into the material yesterday.

2. I ran the canned tool zero function to the top of the material and didn't move any axes before hitting "goto zero." The z axis lifted slightly and then dropped the tool into the material about an inch, and reads 0.000 on the DRO with the bit an inch in the material. There is no longer a chonk but a sort of mechanical bump at the top point of the lift, I haven't been able to identify it yet. This is still a couple inches from the top of the maximum extension of the gas spring, so it's not skipping a gear from hitting the hard stop.

3. I replaced the gas spring just for fun. No change.

Richards Tue 13 November 2018 15:11

I guess I'm not understanding exactly the situation. In electricity, "zero" or "gnd" is the starting point, i.e., 5VDC is five volts above ground. So, the "zero" point when setting tool height, is the point from which all measurements are made. Giving the command, "goto zero", would, by definition, put the tool at the "zero point". Giving the command "G0 Z1.00" would jog to 1.00 above the zero point. Giving the command, "G0 Z -0.25 would put the tool 1/4th inch below the zero reference point.

What is the DRO readout when the tool touches the zero plate? Assuming that it is the thickness of the zero plate, then, with a 1/8" thick plate, the reading would be 0.125", or, 1/8th inch above the desired zero point when the plate is touched and the subroutine resets the zero reference point. Giving the command, "goto zero" would then move the tool down 1/8th inch to the true zero position.

If I understand the problem correctly, your routine sets the zero point to a position about 1" greater than it should be so that when you issue the "goto zero" command, the tool is driven about 1" into the material. If that is what is really happening, then the fix is to change the zero reference number in your zeroing routine to be equal to the thickness of the zero plate.

Remember that a stepper motor has no idea what its true position actually is. If you set the Z-height to a specific location and then remove power from the motor, then any forces acting on the Z-axis might move the axis to another position, i.e., if you use the "disable" command common to many stepper drives, the motor can be pushed or pulled by spring tension or by gravity. Then, when the motor is enabled again, its true position will be unknown. A simple way to check that is to try moving the axis up or down when the spindle is off and the axis is idle. Many stepper drives reduce the holding torque to about 1/2 of full power when an axis is idle for more than a second or two. If the idle torque holding ability of the motor is less than the gas shock pressure against the motor, the axis will be out of position when the axis is re-energized.

(Of course, everything that I've written assumes that you have set the proper number of steps to move the desired distance and that you have selected the proper scale, inches or millimeters. I've learned from having my old Shopbot do weird things that most of the time, I had changed a setting and then not caught the change. The only time I had a real "mystery" was then an axis would suddenly act on its own. One night, well after midnight, I just happened to notice a red indicator light at the base of the computer screen flash exactly when that unexpected axis movement happened. It turned out that I had a wi-fi board in the computer and then when wi-fi went active, the Shopbot software lost control of the machine for an instant. It also turned out that I had installed that wi-fi adapter into the machine on the same day that I installed the spindle onto the machine. In the excitement of getting a spindle, I totally forgot that I had installed the wi-fi adapter, and, since the machine was getting its network data through a wired connection, I didn't notice the problem that the wi-fi adapter was causing until I saw that red indicator blink. Removing the wi-fi adapter immediately fixed the problem.)

Diplocaulus Tue 13 November 2018 17:27

Richards, thanks for the reply. So, I am zeroing to the material, the DRO reads 0.000, but in the auto tool zero program the bit retracts to -1.000 so you can remove the aluminum plate. If I manually jog the z axis to 0.000, it is exactly at the top of the material. If I then move the z axis up, and hit "GOTO ZERO," the tool lifts briefly, then rams into the material about an inch. The DRO still reads 0.000 but something traumatic has obviously happened. This is showing up in my cut files as the bit has eaten a fair amount of the spoilboard. However, news as of today, I was observing this process over and over and realized it might only be doing this with 6" material. I couldn't get it to replicate with any other heights. I'm wondering about my z axis soft limits settings, or something else software related. I cannot see anything mechanical that is interrupting smooth movement of the z axis.

MetalHead Tue 13 November 2018 21:33

Can you shoot a video on your phone and put it on Youtube?

Richards Wed 14 November 2018 12:04

The video that Mike suggested would let others look over your shoulder. If you set the G1 feed rate to a low number so that the DRO can be watched as the z-axis slowly moves, it would be easier to troubleshoot. When the z-zero routine finishes, you should be able to measure the distance between the tool and the material surface with a ruler to verify that it is actually 1" above the material. Assuming that it is, then giving a g1 x 0.50 should stop 1/2" above the material and g1 z 0.00 should stop at the top of the material.

As you've written, if soft-limits are the problem, then the z-axis probably would not be able to move high enough to allow a valid start point. Unfortunately, I've disassembled my Mach3 test bench and replaced it with a Centroid Acorn test bench, so I'm not even able to test movement without using Centroid software.

Diplocaulus Wed 14 November 2018 15:55

Hello, I messed with it again today with the guy who is helping with the spindle setup. We figured out the z axis GOTO zero function had a sort of hidden code that showed a large speed spike at a certain height on the z axis. We fixed the problem by slowing the maximum z speed. I wish I could explain exactly how this worked, but it did. Thanks again for all the help everyone.

bradm Wed 14 November 2018 16:20

Actually, I think that may make sense.

So, your machine zero is working just fine, as confirmed with your DRO and your manual jog.

But you then have some kind of pre-positioning code ( macro in a preprocessor? ) that depends on your material size.

That code contains a speed command that goes faster than the hardware can handle, pushing the motor into a stall condition resulting in the drop.

If that's the case, there are actually two errors here: the cut files that go too fast, and the machine Z configuration that allows it to be attempted.

My guess would be that the Z axis config allows too fast an acceleration, but that full acceleration is rarely reached. The 6" material prep move is about the only time it happens - the rest of the time, you've already started the deceleration before full accel gets reached.

Diplocaulus Wed 26 December 2018 12:44

Brad #10 again, thanks. This error actually hasn't gone completely away. It seems to only skip the gear towards the upper couple inches of travel. I don't know if the speed is still an issue, it might be slightly too fast. I didn't change that setting, another guy did so I don't actually know which menu to access to adjust it. I changed the gear out because it was pretty worn, it wasn't hardened and there isn't a good way to harden the new one so I just went with it. At any rate, the spoilboard is still kind of getting abused but way less than last time. Luckily I'm cutting foam so a single gear slip or two isn't catastrophic.

bradm Wed 26 December 2018 19:33

Upper couple inches of travel? Makes me think about the compensation strut. It will tend to be weaker towards the top as it extends. Maybe it's a little too weak in spec, or worn?

With power off, and Z motor pulled out of the rack, do you notice a difference in movement resistance between the lower and upper portions of the Z range when you push things around?

ger21 Wed 26 December 2018 20:02

Originally Posted by Diplocaulus View Post
So, I am zeroing to the material, the DRO reads 0.000, but in the auto tool zero program the bit retracts to -1.000 so you can remove the aluminum plate.
This sounds like the Z axis is backwards. -1.000 should be 1" below Z zero, not above it.

Diplocaulus Thu 27 December 2018 08:51

Brad, The gas spring is only a month old, so not worn, but the extension that was added before I got here might have not been designed around the gas spring specs. I will look into maybe a stronger one.

IamDave Sun 22 March 2020 15:33

Nothing to do but read old posts, that stop short of a solution. Does it do it on a different sized work piece? (a smaller job).

All times are GMT -6. The time now is 04:15.

Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.